In order for you to install Varnish you must have the following:

  • A recent, preferably server grade, computer.
  • A fairly modern and 64 bit version of either - Linux - FreeBSD, or - Solaris (x86 only).
  • Root access.

Varnish can be installed on other UNIX systems as well, but it is not extensively or systematically tested by us on other systems than the above. Varnish is, from time to time, said to work on:

  • 32 bit versions of the before-mentioned systems,
  • OS X,
  • NetBSD,
  • OpenBSD, and
  • Windows with Cygwin.