[Varnish] #202: Compile Fails on OpenBSD -current / Half a patch provided

Varnish varnish-bugs at projects.linpro.no
Sat Mar 1 20:14:04 CET 2008

#202: Compile Fails on OpenBSD -current / Half a patch provided
 Reporter:  bonetruck  |        Owner:  des     
     Type:  defect     |       Status:  reopened
 Priority:  normal     |    Milestone:          
Component:  build      |      Version:  1.2     
 Severity:  normal     |   Resolution:          
 Keywords:             |  
Comment (by bonetruck):

 I haven't tried porting the math.h stuffs from FreeBSD.  My guess is if
 the core team hasn't already done so, it's beyond me...

 Regardless, I did append the following to bin/varnishd/cache.h

 #ifndef NAN
 #define NAN (0.0/0.0)

 then proceeded to compile successfully on a Netra T1 running sparc64
 OpenBSD-4.3-beta.  Haven't tried running it though.

 Next step is to flesh out a port of 1.1.2 with the two patches and try
 running it.

 Later I would like to try -trunk.  I will have to figure out all the
 autoconf stuff though.  Might be helpful to add those instructions to the
 debugging page on your wiki to facilitate other people helping with the
 toolset slowing them down.

Ticket URL: <http://varnish.projects.linpro.no/ticket/202#comment:8>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator

More information about the varnish-bugs mailing list