[Varnish] #546: Varnish eating up my memory

Varnish varnish-bugs at projects.linpro.no
Wed Sep 2 23:05:58 CEST 2009

#546: Varnish eating up my memory
 Reporter:  hp197     |        Owner:  phk                
     Type:  defect    |       Status:  new                
 Priority:  normal    |    Milestone:  Varnish 2.1 release
Component:  varnishd  |      Version:  trunk              
 Severity:  normal    |   Resolution:                     
 Keywords:            |  
Comment (by hp197):

 We are now using varnish with file cache, but we still see explosive
 memory usage (temporary cache storage?)

 1.5 GiB +   1.2 MiB =   1.5 GiB       /usr/local/varnish/sbin/varnishd -P
 /var/run/varnish_xxx.pid -a :xxx -f
 /usr/local/varnish/etc/varnish/xxx.xxx.xxx.vcl -T :xxx -s
 file,/usr/local/varnish/var/varnish/xxx/cache.pool,5G -i xxx -n
 /usr/local/varnish/var/varnish/xxx -p thread_pools 4 -p lru_interval 1800

 Server above is running +/- 15 minutes and caches only (larger) photos

 Does varnish keep populair objects in shared memory?

 Also tried to build against jemalloc and even tried google's tcmalloc
 (thread safe malloc), but both didn't make much difference.

 P.S. Linpro didnt respond to my mails. So im doing a fallback to the
 community ;-)

Ticket URL: <http://varnish.projects.linpro.no/ticket/546#comment:13>
Varnish <http://varnish.projects.linpro.no/>
The Varnish HTTP Accelerator

More information about the varnish-bugs mailing list