[Varnish] #672: encountered libpcre error when running ./configure

Varnish varnish-bugs at varnish-cache.org
Thu Apr 1 07:22:33 CEST 2010

#672: encountered libpcre error when running ./configure
 Reporter:  flyincat             |        Type:  defect
   Status:  new                  |    Priority:  high  
Milestone:  Varnish 2.1 release  |   Component:  build 
  Version:                       |    Severity:  normal
 Keywords:  libpcre              |  
 Hello, first I'd like to express my appreciation to all the development
 members that you give us a so amazing new release. But, when i'm trying to
 run ./configure after i decompressed the source tar package, there is an
 error as below:
 checking for pkg-config... /usr/bin/pkg-config
 checking pkg-config is at least version 0.9.0... yes
 checking for PCRE... configure: error: Package requirements (libpcre) were
 not met:

 No package 'libpcre' found

 Consider adjusting the PKG_CONFIG_PATH environment variable if you
 installed software in a non-standard prefix.

 Alternatively, you may set the environment variables PCRE_CFLAGS
 and PCRE_LIBS to avoid the need to call pkg-config.
 See the pkg-config man page for more details.

 I'm running ./configure under a X64 HP Server with CentOS 5.4 X64
 installed. and I've already installed pcre-8.2 from the tarball package.

 Any suggestions?
 Thanks a lot for your hard working!

Ticket URL: <http://www.varnish-cache.org/ticket/672>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

More information about the varnish-bugs mailing list