[Varnish] #1008: varnishd not cleaning up temporary files

Varnish varnish-bugs at varnish-cache.org
Sat Sep 3 21:53:17 CEST 2011

#1008: varnishd not cleaning up temporary files
 Reporter:  mikl   |        Type:  defect  
   Status:  new    |    Priority:  normal  
Milestone:         |   Component:  varnishd
  Version:  3.0.1  |    Severity:  normal  
 Keywords:         |  
 I have tried a couple of times setting Varnish up on my Mac. Previously on
 OS X 10.6 and now on 10.7.

 I tried setting it up via the launchd service OS X provides for running

 Each time I've tried, Varnish has repaid me with promptly filling up my
 disks with it's memory files.

 Here's a sample:

 (/usr/local/var/varnish/kerry-pippin.vbg29.local) % la
 -rw-r--r--  1 mikl  wheel    13M  3 Sep 21:31 _.vsm
 -rw-------  1 mikl  wheel   2,3G  3 Sep 21:29 varnish.HD5s3C
 -rw-------  1 mikl  wheel    26G  3 Sep 21:16 varnish.WJZMH8
 -rw-------  1 mikl  wheel   325M  3 Sep 21:31 varnish.WtELtL
 -rw-------  1 mikl  wheel   645M  3 Sep 21:30 varnish.XOY0FO
 -rw-------  1 mikl  wheel    13G  3 Sep 21:21 varnish.Xs2Pah
 -rw-------  1 mikl  wheel   9,0G  3 Sep 21:24 varnish.pgcEjg
 -rw-------  1 mikl  wheel   4,5G  3 Sep 21:27 varnish.z1x6hp
 -rwxr-xr-x  1 mikl  wheel    27K  3 Sep 21:31 vcl.Z4hKfxO9.so

 I think what happens is that I tried to start varnishd with my normal user
 account, which fails. launchd then restarts varnishd after a cool down
 period. Each restart causes it to create a new memory file, and at 13 GB
 each, it tends to fill a 120 GB SSD pretty quickly.

 Perhaps it would be helpful to remove those files when varnish fails to

 (the error I get when starting is “03/09/11 21.21.49,388 org.varnish-
 cache.varnish: Child start failed: could not open sockets”)

Ticket URL: <http://www.varnish-cache.org/trac/ticket/1008>
Varnish <http://varnish-cache.org/>
The Varnish HTTP Accelerator

More information about the varnish-bugs mailing list