[Varnish] #1195: varnishd child will not start

Varnish varnish-bugs at varnish-cache.org
Fri Sep 14 22:10:02 CEST 2012

#1195: varnishd child will not start
 Reporter:  chrcol                     |       Type:  defect
   Status:  new                        |   Priority:  high
Milestone:                             |  Component:  varnishd
  Version:  3.0.2                      |   Severity:  critical
 Keywords:  child process start crash  |

 I run varnish successfully on multiple server's, I then tried to install
 varnish on a virtual machine for a dev environment.

 The vcl config is the same as what works on other machines with only
 changes for backends.

 Upon starting varnishd we discovered that it wasnt responding to requests
 even tho the process was up and after some debugging it turns out the
 child process is crashing immediatly on start.

 Here is the output from debug.

 child (20749) Started
 Pushing vcls failed:
 CLI communication error (hdr)
 Stopping Child
 200 0

 Child (20749) died signal=11
 Child (-1) said Child starts
 Child cleanup complete

 Current param.show although these aren't all normal settings, here I
 raised various timeouts and reduced malloc and thread size to try and get
 it working.

 200 3094
 acceptor_sleep_decay       0.900000 []
 acceptor_sleep_incr        0.001000 [s]
 acceptor_sleep_max         0.050000 [s]
 auto_restart               on [bool]
 ban_dups                   on [bool]
 ban_lurker_sleep           0.010000 [s]
 between_bytes_timeout      60.000000 [s]
 cc_command                 "exec gcc -std=gnu99  -pthread -fpic -shared
 -Wl,-x -o %o %s"
 cli_buffer                 8192 [bytes]
 cli_timeout                60 [seconds]
 clock_skew                 10 [s]
 connect_timeout            10.000000 [s]
 critbit_cooloff            180.000000 [s]
 default_grace              10.000000 [seconds]
 default_keep               0.000000 [seconds]
 default_ttl                14400.000000 [seconds]
 diag_bitmap                0x0 [bitmap]
 esi_syntax                 0 [bitmap]
 expiry_sleep               1.000000 [seconds]
 fetch_chunksize            128 [kilobytes]
 fetch_maxchunksize         262144 [kilobytes]
 first_byte_timeout         10.000000 [s]
 group                      root (0)
 gzip_level                 6 []
 gzip_memlevel              8 []
 gzip_stack_buffer          32768 [Bytes]
 gzip_tmp_space             0 []
 gzip_window                15 []
 http_gzip_support          on [bool]
 http_max_hdr               64 [header lines]
 http_range_support         on [bool]
 http_req_hdr_len           8192 [bytes]
 http_req_size              32768 [bytes]
 http_resp_hdr_len          8192 [bytes]
 http_resp_size             32768 [bytes]
 listen_depth               1024 [connections]
 log_hashstring             off [bool]
 log_local_address          off [bool]
 lru_interval               2 [seconds]
 max_esi_depth              5 [levels]
 max_restarts               4 [restarts]
 nuke_limit                 50 [allocations]
 ping_interval              3 [seconds]
 pipe_timeout               10 [seconds]
 prefer_ipv6                off [bool]
 queue_max                  100 [%]
 rush_exponent              3 [requests per request]
 saintmode_threshold        10 [objects]
 send_timeout               60 [seconds]
 sess_timeout               10 [seconds]
 sess_workspace             16384 [bytes]
 session_linger             50 [ms]
 session_max                100000 [sessions]
 shm_reclen                 255 [bytes]
 shm_workspace              8192 [bytes]
 shortlived                 10.000000 [s]
 syslog_cli_traffic         on [bool]
 thread_pool_add_delay      20 [milliseconds]
 thread_pool_add_threshold  2 [requests]
 thread_pool_fail_delay     200 [milliseconds]
 thread_pool_max            500 [threads]
 thread_pool_min            100 [threads]
 thread_pool_purge_delay    1000 [milliseconds]
 thread_pool_stack          16384 [bytes]
 thread_pool_timeout        300 [seconds]
 thread_pool_workspace      65536 [bytes]
 thread_pools               1 [pools]
 thread_stats_rate          10 [requests]
 user                       nobody (65534)
 vcc_err_unref              on [bool]
 vcl_dir                    /usr/local/etc/varnish
 vcl_trace                  off [bool]
 vmod_dir                   /usr/local/lib/varnish/vmods
 waiter                     default (epoll, poll)

 The os is debian and I gave the virtual machine 2 gigs of ram.

Ticket URL: <https://www.varnish-cache.org/trac/ticket/1195>
Varnish <https://varnish-cache.org/>
The Varnish HTTP Accelerator

More information about the varnish-bugs mailing list