[experimental-ims] 21eb82b Rename variable to not confuse people on monday mornings.

Geoff Simmons geoff at varnish-cache.org
Tue Feb 14 17:49:28 CET 2012


commit 21eb82b4a96e270e12d0aa8b9b95d2c1a31a7fc9
Author: Poul-Henning Kamp <phk at FreeBSD.org>
Date:   Mon Feb 13 09:18:50 2012 +0000

    Rename variable to not confuse people on monday mornings.

diff --git a/bin/varnishd/cache/cache_wrk.c b/bin/varnishd/cache/cache_wrk.c
index c1d20e8..98de83f 100644
--- a/bin/varnishd/cache/cache_wrk.c
+++ b/bin/varnishd/cache/cache_wrk.c
@@ -131,13 +131,13 @@ WRK_BgThread(pthread_t *thr, const char *name, bgthread_t *func, void *priv)
 /*--------------------------------------------------------------------*/
 
 static void *
-wrk_thread_real(void *priv, unsigned shm_workspace, unsigned sess_workspace,
+wrk_thread_real(void *priv, unsigned shm_workspace, unsigned thread_workspace,
     unsigned siov)
 {
 	struct worker *w, ww;
 	uint32_t wlog[shm_workspace / 4];
 	/* XXX: can we trust these to be properly aligned ? */
-	unsigned char ws[sess_workspace];
+	unsigned char ws[thread_workspace];
 	struct iovec iov[siov];
 
 	THR_SetName("cache-worker");
@@ -152,7 +152,7 @@ wrk_thread_real(void *priv, unsigned shm_workspace, unsigned sess_workspace,
 	w->wrw.ciov = siov;
 	AZ(pthread_cond_init(&w->cond, NULL));
 
-	WS_Init(w->aws, "wrk", ws, sess_workspace);
+	WS_Init(w->aws, "wrk", ws, thread_workspace);
 
 	VSL(SLT_WorkThread, 0, "%p start", w);
 



More information about the varnish-commit mailing list