[4.0] 228055e python-docutils v0.6 will have to do.

Lasse Karstensen lkarsten at varnish-software.com
Tue Jun 24 11:31:56 CEST 2014

commit 228055ea74aa509b4379025317b560066714a839
Author: Lasse Karstensen <lkarsten at varnish-software.com>
Date:   Fri Jun 20 17:03:25 2014 +0200

    python-docutils v0.6 will have to do.
    Seems like requiring a version from 2010 was way optimistic.
    EL6 has v0.6 which was the first version rst2man appeared in.

diff --git a/doc/changes.rst b/doc/changes.rst
index 2ee4aeb..a66bda1 100644
--- a/doc/changes.rst
+++ b/doc/changes.rst
@@ -17,7 +17,7 @@ New since 4.0.0:
 - Added format flags %I (total bytes received) and %O (total bytes sent) for
-- python-docutils >= 0.7 is now required.
+- python-docutils >= 0.6 is now required.
 - Support year (y) as a duration in VCL.
 - VMOD ABI requirements are relaxed, a VMOD no longer have to be run on the
   same git revision as it was compiled for. Replaced by a major/minor ABI counter.
diff --git a/redhat/varnish.spec b/redhat/varnish.spec
index ec81229..b50c859 100644
--- a/redhat/varnish.spec
+++ b/redhat/varnish.spec
@@ -18,7 +18,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 # You will need at least automake autoconf libtool
 #BuildRequires: automake autoconf libtool
 BuildRequires: ncurses-devel groff pcre-devel pkgconfig libedit-devel jemalloc-devel
-BuildRequires: python-docutils >= 0.7
+BuildRequires: python-docutils >= 0.6
 Requires: varnish-libs = %{version}-%{release}
 Requires: logrotate
 Requires: ncurses

More information about the varnish-commit mailing list