[master] 110e7c5d5 Purely cosmetic: VCL_Poll() should be called inside cli_mtx.

Poul-Henning Kamp phk at FreeBSD.org
Mon Feb 27 14:44:05 UTC 2023


commit 110e7c5d5aafba1d72f73e35fd019959854a3a5c
Author: Poul-Henning Kamp <phk at FreeBSD.org>
Date:   Mon Feb 27 14:42:40 2023 +0000

    Purely cosmetic: VCL_Poll() should be called inside cli_mtx.

diff --git a/bin/varnishd/cache/cache_cli.c b/bin/varnishd/cache/cache_cli.c
index e5006f8de..2dd203597 100644
--- a/bin/varnishd/cache/cache_cli.c
+++ b/bin/varnishd/cache/cache_cli.c
@@ -76,8 +76,8 @@ cli_cb_before(const struct cli *cli)
 
 	ASSERT_CLI();
 	VSL(SLT_CLI, NO_VXID, "Rd %s", VSB_data(cli->cmd));
-	VCL_Poll();
 	Lck_Lock(&cli_mtx);
+	VCL_Poll();
 }
 
 static void


More information about the varnish-commit mailing list