[master] fc2445bf7 vbp: Rename vbp_thread to vbp_scheduler for clarity

Nils Goroll nils.goroll at uplex.de
Mon Jul 15 18:29:03 UTC 2024


commit fc2445bf7107e85ff977f7db49067d695d71ebf9
Author: Nils Goroll <nils.goroll at uplex.de>
Date:   Tue Jul 9 15:52:50 2024 +0200

    vbp: Rename vbp_thread to vbp_scheduler for clarity
    
    This background thread does not run the actual probes, but schedules tasks which
    do (vbp_task).
    
    Rename suggested by phk.

diff --git a/bin/varnishd/cache/cache_backend_probe.c b/bin/varnishd/cache/cache_backend_probe.c
index feb9b91a4..ee9f98bfc 100644
--- a/bin/varnishd/cache/cache_backend_probe.c
+++ b/bin/varnishd/cache/cache_backend_probe.c
@@ -499,7 +499,7 @@ vbp_task(struct worker *wrk, void *priv)
  */
 
 static void * v_matchproto_(bgthread_t)
-vbp_thread(struct worker *wrk, void *priv)
+vbp_scheduler(struct worker *wrk, void *priv)
 {
 	vtim_real now, nxt;
 	struct vbp_target *vt;
@@ -808,5 +808,5 @@ VBP_Init(void)
 	vbp_heap = VBH_new(NULL, vbp_cmp, vbp_update);
 	AN(vbp_heap);
 	PTOK(pthread_cond_init(&vbp_cond, NULL));
-	WRK_BgThread(&thr, "backend-poller", vbp_thread, NULL);
+	WRK_BgThread(&thr, "backend-probe-scheduler", vbp_scheduler, NULL);
 }


More information about the varnish-commit mailing list