varnishd -lssl

Peter Janovsky peterjanovsky at
Wed Mar 31 17:34:37 CEST 2010

thnx for all your help.  figured out the issue.  it was a problem with locating the shared library.  i went back to scratch, rebuilt the library and ensured it was properly loaded and could be located by ld.  the following command worked like a charm when compiling my vcl

/usr/sbin/varnishd -C -f /etc/varnish/default.vcl -p cc_command="exec cc -L /usr/lib/FULL_NAME_OF_SHARED_LIBRARY -l LIBRARY_NAME-fpic -shared -Wl,-x -o %o %s -lssl"

i may not be 100% familiar with the varnish wiki but is this information posted in one place?  if not i'd be glad to share it as it took me a while to figure out, and was only able to figure it out with the help of users on the listserv.  or is the listserv used as a reference tool?

From: Nils Goroll <slink at>
To: Peter Janovsky <peterjanovsky at>
Cc: Tollef Fog Heen <tfheen at>; Varnish Development <varnish-dev at>
Sent: Tue, March 30, 2010 4:28:07 AM
Subject: Re: varnishd -lssl

Hi Peter,

> i've also attempted using the -L and -l options to specify the shared
> library's location and soname, still no progress.

Does -R help to specify the runtime linker path?

Otherwise I suggest you post specific error messages and the exact
commands/settings you're using.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the varnish-dev mailing list