director error messages

Per Buer perbu at
Fri Feb 21 11:19:22 CET 2014


I'm going through the docs and updating the various bits to V4. When
testing the directors I ran into the following error message:

:varnish perbu$ ./bin/varnishd/varnishd -a :2000 -d -f /tmp/test.vcl
Message from VCC-compiler:
Not running as root, no priv-sep
Missing errorhandling code in parse_new(), vcc_action.c line 193:
  Condition((sy2) != 0) not true.
Running VCC-compiler failed, signal 6

VCL compilation failed

This is the VCL I tried to compile:

vcl 4.0;

backend server1 {
             .host = "";

backend server2{
             .host = "";

sub vcl_init {
    new bar = directors.round_robin();
    bar.add_backend(server1, server2);

The error message isn't really helpful and I think this is a bug in the VCL

 <> *Per Buer*
CTO | Varnish Software
Phone: +47 958 39 117 | Skype: per.buer
We Make Websites Fly!

Winner of the Red Herring Top 100 Global Award 2013
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the varnish-dev mailing list