[PATCH] Change hash_data() input type to BLOB

Poul-Henning Kamp phk at phk.freebsd.dk
Mon Apr 20 22:33:22 CEST 2015

In message <CAJV_h0bcyLOktmbeg8xm35Z3ep_LrMWK4sMdYVuUHn-NnM5qaw at mail.gmail.com>
, Federico Schwindt writes:

>Duh! New diff attached. Documentation and tests remaining. Something like

I would prefer to put it in vmod_std, rather than special-case
it in VCC...

>Should we keep hash_data() or rename it to hash_string() or something

I would just leave that alone, and add std.hash_blob() for the special

Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
phk at FreeBSD.ORG         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

More information about the varnish-dev mailing list