varnishstat broken in 3.0.2 release

Chris chrcoluk at
Fri Jan 13 05:23:01 CET 2012


we adopted varnish towards the end of last summer in 2011 and as such
we started out with varnish 3.0.0 as our first version.

Initially when using this version varnishstat worked fine all the
time, however due to other (serious) bugs in 3.0.0 we upgraded to

Now varnishstat will work for a short time after varnish is started
but within a day of uptime it stops working and displays no values.  I
dont know the exact time it takes to stop working but it is under a

Here is the syntax I am using to start varnish, it is running on
FreeBSD 8.2 64bit with 18gig of ram and a 4 core intel system.

varnishd -f /usr/local/etc/varnish/default.vcl -s malloc,12G -p
default_ttl=14400 -p thread_pools=4 -p thread_pool_min=200 -p
thread_pool_max=4000 -p thread_pool_add_delay=2 -p session_linger=100
-T -S /usr/local/etc/varnish/auth -a

reccomended tuning has been carried such as increasing file descriptor
limits, max threads per proc limit and max sockets limits.

the actual performance of varnish is not in question and it runs very
well from what I can see.  It is on averaging dealing with 500-800
hits/sec with about 160-200 going to the backend.  The hit rate is
around 90% but about 1/5th of hits are passed to the backend. "cache
hits for pass"

Also I tried to register this as a bug however the bug page on
varnish's website the security question always fails, name a function
of varnish.


More information about the varnish-dist mailing list