Problem with Varnish.

Your Friend parsimail2001 at
Mon Jul 11 14:59:19 CEST 2011

Thanks for your response. 
The version of Varnish is 2.1.3-8, latest stable version for Debian, I used APT.

I tried to run varnishlog, than I clicked on the link 2, a few second later I got kicked out of server (ssh)!
I think it's more like some security issue, I also checked server logs, I know it's firewall disconnecting client. But only if I use Link 2. maybe I wrote someting wrong in the conf file?

--- Den mån 2011-07-11 skrev Traian Bratucu <traian.bratucu at>:
Hello,  From what I can see, your problem might not be with varnish. As far as i know, varnish would return a 503 error on backend failure, you would never get redirected to, as you say it is happening to you.  Please try to use the command “varnishlog” to see exactly what is happening to the request. Also, posting which version of varnish (2.x or 3) you are using might also help.  Regards,Traian  Hey,  I posted my vcl conf yesterday and still no response, is this forum active? shall I give up on varnish?  Anyone who can help me with the issue?   
--- Den sön 2011-07-10 skrev Shibashish <shib4u at>:hey, here is my vcl file:I commented out "sub vcl_fetch" because I got error while starting varnish.  backend default {
.host = "";
.port = "81";
sub vcl_recv {
# add a unique header containing the client IP address
set req.http.X-Orig-Forwarded-For = client.ip;

# we're only handling static content for now so remove any
# Cookie that was sent in the request as that makes caching
# impossible.
if (req.url ~ "\.(jpe?g|png|gif|ico|js|css|zip|CSS|mp3|wma|wmv|avi)(\?.*|)$") {
unset req.http.cookie;

#sub vcl_fetch {
# if the backend server adds a cookie to all responses,
# remove it from static content so that it can be cached.
# if (req.url ~ "\.(jpe?g|png|gif|ico|js|css|zip|CSS|mp3|wma|wmv|avi)(\?.*|)$") {
# unset obj.http.set-cookie;
# }#}    Hey guys,  I am fairly new to the Varnish, I installed Varnish as the frontend to nginx, everything works fine föruton a strange problem that I have never encountered before when I used only the nginx;

I have an index page that links to the archives of this dress in two different ways:
Link 1:
Link 2:

Here comes the problem, with Varnish does not link two work, the browser simply can not access the page and after a few seconds, nothing appears in the browser and the address bar shows the address that a page can not be reached, the address that appears in the address bar is:

Configuration of the Web server is and Varnish 80.

I don't use htaccess.

I would be grateful if you help me with this problem.Thanks!
varnish-misc mailing list
varnish-misc at  Please post your vcl file.
while ( ! ( succeed = try() ) );  
-----Infogad bilaga följer-----

varnish-misc mailing list
varnish-misc at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the varnish-misc mailing list