Varnish is functioning and caching but varnihstat show no hits

Raymond Jennings raymond.jennings at
Tue Feb 18 14:03:48 CET 2014

There is also a problem where your host name changes after Varnish
starts.  It's looking for the cache location based on the new host
name instead if the old host name.  Varnish stat and varnish history
fail.  This is a bug to me but Varnish thinks otherwise.  If you are
writing to a file based on host name you can easily keep track of what
that host name was.  This is a common problem on AWS ec2.

> On Feb 18, 2014, at 6:20 AM, Lasse Karstensen <lkarsten at> wrote:
>> On Wed, Feb 05, 2014 at 12:38:32PM -0500, Matt Collier wrote:
>> I am running varnish v. 3.05 on a debian server. I have had varnish
>> running on this server for a long while now and I am not having any
>> problems with the installation except:
> [..]
>> When I run varnishstat, my hit ratio is 0, and when I run
>> varnishstat -1 it shows 0 client connections accepted.  I can also
>> add that the server uptime displayed in the upper left hand corner
>> of varnishstat is does not appear to be incrementing properly.  It's
>> been sitting at 0+00:00:00 for the last hour.
> [..]
>> I can add that I upgraded varnish from 3.0.2-3 to 3.0.4-1 in August
>> of last year.  I upgraded from 3.04 to 3.05 today.
> This is probably due to a dependency problem for libvarnishapi in
> the older packages.
> Make sure that you have the correct (same) version of all varnish packages
> installed on the system.
> --
> With regards,
> Lasse Karstensen
> Varnish Software AS
> _______________________________________________
> varnish-misc mailing list
> varnish-misc at

More information about the varnish-misc mailing list