Varnishd stops sending logs to VSM after a while

Raymond Jennings raymond.jennings at
Thu Mar 13 12:33:03 CET 2014

I have what might be a related problem.  I can only get varnishlog to
write to a file after I stop it and restart it.  I am running on ec2.
I tried various tricks to wait so many seconds after varnished starts
then start varnishlog.   Varnishncsa runs perfectly fine right out of
the gate.  I have had this problem for about two years now.
Varnishlog is clearly running and "service varnishlog stop"
successfully stops it.   "service varnishlog start" and things are

> On Mar 13, 2014, at 6:27 AM, Thomas Lecomte <thomas.lecomte at> wrote:
>> On Thu, Mar 13, 2014 at 10:25:52AM +0100, Cédric Jeanneret wrote:
>> Hmm, _.vsm is shown when we perform a simple "ls" in the directory...
>> Else, I would get some errors from either varnishncsa or varnishlog when
>> I start them (I tried that this morning, just to see what would happen)...
> Maybe you could compare the inodes using ls -i on the visible _.vsm
> against the one shown by lsof on the varnish process.
> --
> Thomas Lecomte / +33 4 86 13 48 65
> Sysadmin / Virtual Expo / Marseille
> _______________________________________________
> varnish-misc mailing list
> varnish-misc at

More information about the varnish-misc mailing list