Random "Data not received" with Varnish behind ELB

Greg Taylor greg at pathwright.com
Mon Oct 20 22:50:35 CEST 2014

We've been running Amazon Elastic Load Balancer (ELB) as our front-facing
reverse proxy and SSL terminator, with a pool of Django app servers behind
it. This setup has worked very well for us for about four years now.

To help withstand some bursty traffic from one of our customers, we worked
Varnish in behind ELB and in front of our Django app servers. For the most
part, this went over very well. The only issue is that some (but not all)
of our users are now seeing intermittent "No data received" errors. This
looks to mostly be happening with Chrome (but not Chromium on Linux).
Here's what it looks like:


This error is seen every once in a while inconsistently when browsing
around. Whether the page is a cache hit or miss doesn't seem to matter. One
of our users has been able to replicate the issue by closing Chrome
entirely, then visiting the site. I haven't been able to reproduce it at
all on Chromium + Linux.

If we yank Varnish out, the problem goes away immediately. Here's what our
varnish config looks like atm:


Here's our test site:


Any help or ideas would be greatly appreciated. We'd really like to use
Varnish for this upcoming traffic burst, but we had tons of complaints
about this error when we flipped it on the first time.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.varnish-cache.org/lists/pipermail/varnish-misc/attachments/20141020/dc78cd5b/attachment.html>

More information about the varnish-misc mailing list