Why doesn't varnish cache these requests?

Rainer Duffner rainer at ultra-secure.de
Wed Jan 27 01:22:10 CET 2016

> Am 26.01.2016 um 17:35 schrieb Andri Steiner | snowflake Hosting <hosting at snowflake.ch>:
> Does not matter as it seems you have TYPO3 configured properly because
> otherwise the TYPO3-* headers would not be there at all. BTW, you could
> add your backend server to the "ban" ACL, without this the TYPO3 Backend
> wont be allowed to purge the Varnish cache.

Yes, I did that now.

The site is still in development and all the typo3 stuff is done by someone else (i.e. 3rd party).
Maybe they fixed it in the meantime.  Though, it should have come from nginx anyway.

Because I see that I get a HIT now, using curl.

Which is a bit puzzling.

Though, when I use FF + Firebug, I still get a MISS. Somehow, somewhere, it’s still cached in the browser :-(
In Opera, I do see the HITs.

Still, I’ve got a loading-time for the larger images that looks a bit too much.

Site has 49 elements, 3.1MB.
Though, when I check your company’s start-page with the various tools out there, it shows similar behavior with larger images.

The site takes <2s to load on my 20/2 DSL.
Loading times vary depending on the location. I get 5-6s from various European locations via webpagetest.org <http://webpagetest.org/>, and about 10-12 seconds via Asia and 5-6 seconds from the US.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.varnish-cache.org/lists/pipermail/varnish-misc/attachments/20160127/52b21e33/attachment.html>

More information about the varnish-misc mailing list