[PATCH] Add a flag to mark 304 backend response processing (aka, Backend IMS/INM)
slink at schokola.de
Tue Mar 10 23:54:49 CET 2015
On 10/03/15 21:53, Poul-Henning Kamp wrote:
> I think the name looks ugly-ish, but I can't decide if I think there is
> value in explicitly mentioning 304 vs. more clarity in a more descriptive
> name (beresp.was_refreshed, beresp.refreshed ...)
I've named it was_304 now as the 304 was already a thing of the past when the
flag is seen.
<irrelevant side note>
Other than that, please let's keep the mnemonic 304. Personally, I could never
remember if it's beresp.uncacheable or beresp.cacheable (and have not looked
that up now) and would really have preferred something like beresp.was_pass.
</irrelevant side note>
More information about the varnish-dev