[master] cbe8047 Reintroduce hit-for-pass with new and better syntax:

Dridi Boukelmoune dridi at varni.sh
Wed Feb 22 14:12:32 CET 2017

On Wed, Feb 22, 2017 at 2:04 PM, Poul-Henning Kamp <phk at freebsd.org> wrote:
> commit cbe804760d78b917fbbb8a1d69b2236a2d98a028
> Author: Poul-Henning Kamp <phk at FreeBSD.org>
> Date:   Wed Feb 22 10:40:58 2017 +0000
>     Reintroduce hit-for-pass with new and better syntax:
>         sub vcl_backend_response {
>                     return (pass(2s));
>             }

We need to clear the confusion of turning hitpass into a hitmiss in
5.0, while keeping the MAIN.cache_hitpass counter as is. Especially
now that hitpass lives alongside hitmiss.

Also, should the built-in VCL make a distinction between hitmiss and
hitpass? For example if the response contains a Set-Cookie header it
might be a one-time thing and hitmiss would be preferred, otherwise it
looks like something reliably not cacheable: so hitpass.



More information about the varnish-dev mailing list