Changes in vcl

Rob Brown dtownrobbrown at
Fri May 14 19:50:51 CEST 2010

On Fri, May 14, 2010 at 3:37 AM, Paras Fadte <plfgoa at> wrote:

> Hi ,
> Have changes been made in vcl such that "obj.cacheable" is now referred to
> as "beresp.cacheable" . Is this the only change ? Is this change applicable
> in all functions in vcl configuration file or just limited to some functions
> . example only in vcl_fetch "obj" is replaced by "beresp".
> Thank you.
> -Paras
 Ah, yes... I ran into this same issue because I had originally set up
Varnish on a test Ubuntu workstation and just installed the package from the
repository, which happened to be v.2.0.3. I had my config all dialed in and
working there, and then built a new box with CentOS and installed the 2.1
RPM from sourceforge. When I copied my "working" config over and tried to
start varnishd, it just "died". No error message. Nothing. Took me a good
chunk of time of debugging before I finally ran across the note in the
changelog and was like "ah ha!".
It would be nice if:
a) There was some syntax checking on startup that would tell you that obj is
not valid in vcl_fetch (anymore).
b) Put a note on WIKI pages that have "example" configs that will only work
on 2.0.
(I'll volunteer for b if someone wants to send me the code to edit wiki).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the varnish-misc mailing list