Random "Data not received" with Varnish behind ELB

Greg Taylor greg at pathwright.com
Mon Oct 20 23:48:18 CEST 2014

We're terminating HTTPS on the ELB level, so Varnish doesn't really know or
care what protocol is being used.

On the ELB level, we have disabled SSLv3, but this particular quirk (The
"No data received" error) occurs with and without SSLv3 in ELB's

My initial theory was that something was timing out somewhere in the stack
(ELB->Varnish->App server), but I haven't been able to back that up with
anything concrete. I've upped the timeouts across the board to test the
theory with no improvement in behavior.

On Mon, Oct 20, 2014 at 5:24 PM, nick tailor <nick.tailor at gmail.com> wrote:

> Are these doing any SSL?
> This could be related to poodle bug, a lot of people are disabling sslv3
> and only using tls1.0+.
> The handshake if using ssl could your problem, however just a guess based
> on its around the same time poodle was released.
> Cheers
> Nick Tailor
> nicktailor.com
> On Mon, Oct 20, 2014 at 1:50 PM, Greg Taylor <greg at pathwright.com> wrote:
>> We've been running Amazon Elastic Load Balancer (ELB) as our front-facing
>> reverse proxy and SSL terminator, with a pool of Django app servers behind
>> it. This setup has worked very well for us for about four years now.
>> To help withstand some bursty traffic from one of our customers, we
>> worked Varnish in behind ELB and in front of our Django app servers. For
>> the most part, this went over very well. The only issue is that some (but
>> not all) of our users are now seeing intermittent "No data received"
>> errors. This looks to mostly be happening with Chrome (but not Chromium on
>> Linux). Here's what it looks like:
>> http://imgur.com/HRkNO6u
>> This error is seen every once in a while inconsistently when browsing
>> around. Whether the page is a cache hit or miss doesn't seem to matter. One
>> of our users has been able to replicate the issue by closing Chrome
>> entirely, then visiting the site. I haven't been able to reproduce it at
>> all on Chromium + Linux.
>> If we yank Varnish out, the problem goes away immediately. Here's what
>> our varnish config looks like atm:
>> https://gist.github.com/gtaylor/ba1ea77b68bd84664e85
>> Here's our test site:
>> http://littlepeople.pathwright.com
>> Any help or ideas would be greatly appreciated. We'd really like to use
>> Varnish for this upcoming traffic burst, but we had tons of complaints
>> about this error when we flipped it on the first time.
>> _______________________________________________
>> varnish-misc mailing list
>> varnish-misc at varnish-cache.org
>> https://www.varnish-cache.org/lists/mailman/listinfo/varnish-misc
> --
> Nick Tailor
> Senior Linux Systems Administrator
> BCLC, 2940 Virtual Way, Vancouver B.C. V5M 0A6
> T 604 228 3046  C 778 388 1397
> Connect with us:
> Twitter @BCLC <http://twitter.com/BCLC>| Twitter @BCLCGameSense
> <http://twitter.com/BCLCGameSense> | YouTube
> <http://youtube.com/user/BCLCPlayingItRight/videos> | Blog
> <http://blogs.bclc.com/> | bclc.com <http://www.bclc.com/>
>  Last year, more than $1 billion generated by BCLC gambling activities
> went back into health care, education and community groups across B.C.

Greg Taylor,
Pathwright Co-founder
(864) 334-8735
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.varnish-cache.org/lists/pipermail/varnish-misc/attachments/20141020/ecf6485c/attachment-0001.html>

More information about the varnish-misc mailing list