Random "Data not received" with Varnish behind ELB

Greg Taylor greg at pathwright.com
Wed Oct 22 18:23:17 CEST 2014

We managed to find what appears to be one of these failed requests:

2014-10-22T15:47:56.092374Z littlepeople - -1 -1 -1
408 0 0 0 "GET http://littlepeople.pathwright.com:80/ HTTP/1.1"

Says request timeout. I've got my ELB timeout set to 6 seconds, and
varnish's default idle_timeout is 10s. I have also added this:

sub vcl_pipe {
    # Don't re-use backend connections.
    set bereq.http.Connection = "close";

None of this seems to have made any difference, though. Any further ideas
on how to handle this?

On Mon, Oct 20, 2014 at 5:50 PM, Paul Armstrong <psa at otoh.org> wrote:

> At 2014-10-20T16:50-0400, Greg Taylor wrote:
> >    We've been running Amazon Elastic Load Balancer (ELB) as our
> >    front-facing reverse proxy and SSL terminator, with a pool of Django
> >    app servers behind it. This setup has worked very well for us for
> about
> >    four years now.
> Have you tried turning on ELB logging and seeing if the ELB reports
> something interesting for such broken queries?
> Paul

Greg Taylor,
Pathwright Co-founder
(864) 334-8735
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://www.varnish-cache.org/lists/pipermail/varnish-misc/attachments/20141022/b0ef5bcb/attachment.html>

More information about the varnish-misc mailing list