name changes for the upcoming 4.0
perbu at varnish-software.com
Mon Dec 5 11:34:48 CET 2011
At some point we'll make a 4.0 release and I'll thought I'll raise a
suggestion. This is mostly based on feedback from people that are new
to Varnish. A few of the names we've chosen are pretty uninformative.
The good thing is that this forces people to read the docs. On the
flip side it doesn't convey anything at all about what the function
actually does and so the functionality here is mostly out of the reach
of most of the users.
There are several ways of addressing this. Some more involved than
others. One very simple way would be a simple rename.
The Squid people call this stale-while-revalidate which I think is an
OK name. It tells us a lot more than what grace does.
2) saint mode
I think the squid people (I know, that sounds weird) has something
that roughly matches. They call this stale-if-error. While not
completely accurate it is not bad. We might also consider something
Today, grace is set in vcl_fetch also. I think it would make sense to
change this to something like keep-past-ttl.
stale-while-revalidate/grace would still be set in vcl_recv. This also
makes sense for the upcoming IMS against backend.
One forth and not related issue is "ban". We've already renamed this
once. Most people seem to get anchored to some perception that this
has to do with banning someone from getting content. My best
suggestion for a new name would be "purge-filter". Tollefs suggestion
is "invalidate" which might cover it better.
What do you think?
Per Buer, Varnish Software
Phone: +47 21 98 92 61 / Mobile: +47 958 39 117 / Skype: per.buer
Varnish makes websites fly!
Whitepapers | Video | Twitter
More information about the varnish-dev